[Xerte] Problem with installer

Brian Chivers brian at portsmouth-college.ac.uk
Fri Jan 25 15:46:01 GMT 2013

I've just tried to install Xerte toolkit 1.9 onto a freshly setup Ubuntu 
12.04 LTS server running the latest mysql / php stack and have run into 
a problem with the installer php scripts.

The server has a FQDN of xerte.portsmouth-college.ac.uk and when I run 
setup/mysql_test.php on the test where it checks connectivity I get this 

Due to the following error - You have an error in your SQL syntax; check 
the manual that corresponds to your MySQL server version for the right 
syntax to use near '-college.ac.uk' at line 1 - 1064 we cannot ascertain 
whether we can create this database

It would appear that it isn't escaping the FQDN correctly causing the 
mysql statement to fail.

If I rename the server to use our secondary domain tpc.ac.uk the 
installer goes through fine so I know there is nothing wrong with the 

I still have the first server so if required I can test altered php files.

Brian Chivers

More information about the Xerte mailing list